PDF Generating Tool Support Forum

HOME   Login   Register    Search

  Subject: Blank PDF document because of single commas in HTML
   PostPosted: 18 May 2011, 00:09 
Hi, I use PD4ML 3.70 and found one problem - if there is a single comma ['] in CSS part and another one in page body, output PDF document will be blank.

I paste sample HTML code here. It has 2 single commas.
If you'll remove one of them, PDF document will be produced, otherwise it will be blank.

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>A Plus Payroll Document</title>
<style type="text/css">
body {
   font: 100% Calibri, Calibri, Calibri, sans-serif;
   background: #FFFFFF;
   margin: 0; /* it's a test */
   padding: 0;
   text-align: center;
   color: #000000;
.oneColFixCtrHdr #container {
   width: 720px; 
   background: #FFFFFF;
   margin: 0 auto;
   border: 1px solid #000000;
   text-align: left;
.oneColFixCtrHdr #header {
   background: #FFFFFF;
.oneColFixCtrHdr #body {
   background: #FFFFFF;
   padding:0 20px;
.oneColFixCtrHdr #header h1 {
   margin: 0;
   padding: 10px 0;
.oneColFixCtrHdr #mainContent {
   padding: 0 20px;
   background: #FFFFFF;
.oneColFixCtrHdr #footer {
.oneColFixCtrHdr #footer p {
   margin: 0;
   padding: 10px 0;
.style2 {font-size: small}
.style3 {
   font-family: Calibri, Calibri, Calibri, sans-serif;
   font-size: smaller;
.style9 {font-family: Calibri, Calibri, Calibri, sans-serif; font-size: x-small; }
.style11 {
   color: #000000
.style12 {
   font-family: Calibri, Calibri, Calibri;
   font-size: x-small;
   color: #000000;
.style13 {
   font-family: Calibri, Calibri, Calibri;
   font-size: smaller;
   color: #000000;
<table width=400>
     <td>W-2's and Electronic Filing Base Fee</td>

I used old version of PD4ML before, and it was working without any problem.
Could you please fix it or explain why it doesn't work?

  Subject: Re: Blank PDF document because of single commas in HTML
   PostPosted: 18 May 2011, 14:25 
It is a strange issue and I do not believe it is caused by a PD4ML bug (bearing in mind it splits HTML and CSS and parses them separately). I tried to convert your sample offline with a command-line PD4ML tool and got predictable results. See attached.

Also as I see your HTML has placeholders ($opportunity). Could it be the issue comes from the runtime, which pre-process the HTML?

pd4ml2973.pdf [31.1 KiB]
Downloaded 98 times

[Reply]     [ 2 posts ] 

Copyright ©2004-10 zefer|org. All rights reserved. Bookmark and Share