PDF Generating Tool Support Forum

HOME   Login   Register    Search




  Subject: Images are not displaying in PDF (PD4ML generation)
   PostPosted: 03 Jan 2018, 12:34 
Attachment:
File comment: ttf font files available in server path
List of ttf_Server.txt [713 Bytes]
Downloaded 63 times
Hi,

We have a requirement to generate PDF with 31 international languages through PEGA. So, we used required ttf font files and PD4ML JAR (Version: 390 Pro DMS) to generate font properties file (http://pd4ml.com/cookbook/pd4ml_pdf_true_type_fonts.htm). We are able to generate pdf but facing below issues. Could you please let us know what’s causing these issues and help to get out of this.

1. Images are not displaying in generated PDF. We are having images in local path of PEGA like “Webwb/”.
2. Only for 5 languages Cambodian, Amharic, Gujarati, Laotian, Punjabi generated PDF is displaying junk ‘?’ characters. Even though we loaded all the required ttf fonts files into path.

Attached the Java code “GeneratePDF-UsingPD4ML.txt” which is used to generate PDF and list of ttf font files available in server “List of ttf_Server.txt” .


Attachments:
File comment: java code used to generate PDF
GeneratePDF-UsingPD4ML.txt [1.21 KiB]
Downloaded 78 times
  Subject: Re: Images are not displaying in PDF (PD4ML generation)
   PostPosted: 04 Jan 2018, 11:56 
Now fonts issue was resolved, we are able to get all the foreign languages in to PDF without junk(?) characters.


  Subject: Re: Images are not displaying in PDF (PD4ML generation)
   PostPosted: 07 Aug 2018, 16:56 
Were you able to solve the images not displaying issue? I have the same problem using Pega as well.



[Reply]     [ 3 posts ] 

cron
Copyright ©2004-10 zefer|org. All rights reserved. Bookmark and Share