I can generate the entire content only if I explicitly define the document height:
body { height: 150cm; }

Your HTML layout consists of absolutely positioned blocks. Such layout for some reason makes actual document height computation incorrect. I’ve opened the internal ticket to fix the issue with the top priority. But the above style can be used as a temporal workaround.

> Moreover we are not setting any page margins, all we are doing is setting insets.
In PD4ML v3 we called the “page margins” as “page insets”. But they mean the same in the context.