Thanks for your response.
I have changed the weblogic server start parameter to add
-Dweblogic.webservice.i18n.charset=utf-8 and restarted the server. No luck.

then I added the below parameter and restarted the server.

Weblogic Domain path-> bin folder -> setDomainEnv.sh under JAVA_OPTS added the below variable.

Still it is displaying the same characters. Plz help me what could be the problem.