It turns out that as soon as I set table width to 100% (in page which is in landscape mode) first page of the PDF shrinks by some 20%.
What fixes first page is to set table width also to 100% but then all columns in that page must also be set to a percentage value, pixels will not work as page will remain shrunk. This is very inconvenient as if you copy-paste HTML into an external editor and resize columns, tab widths will automatically be rest to pixel values which again means that page will be shrunk.
I suppose one thing to try is to hardcode landscape page table width to a pixel rather than percentage value but that is hardcoding and I don’t really like to do that.
I will play with it a bit more, I was hoping that somebody came across this already. If I find a usable solution I will post it here.

Just out of interest, if you have the time, try setting orientation of one of pages to landscape then set table width of that page to 100%. Try generating document and let me know if first page shrinks, it will be much appreciated.