Viewing 15 posts - 1 through 15 (of 33 total)
  • Author
  • #26712

    For some reason PD4ML suddenly doesn’t function on my system (which happens to be Macintosh).
    I have 3.8.0

    The only reason I can think of is my recent system update to Lion. Anybody else had a problem with PD4ML on Lion?

    The problem is pretty odd. I get no errors in my logs.
    After turning on debugging, in one case it tells me that it’s created a .pdf when it’s done nothing at all. Then everything just stops. It took me ages to work out that the problem was with PD4ML because there were absolutely no errors in my logs anywhere.

    In another debugging – for a different page – the debug just tells me the version number of PD4ML then does nothing else. Nothing is produced any more in any of the programmes that use PD4ML, at least in the tagged versions. I haven’t tried to check the .java api.

    If anybody’s got any ideas, they would be very welcome.


    Could it be a 64-Bit issue?


    I’ve just updated JDK on my Mac workstation to the most actual state and tested PD4ML – everything works fine (as before).

    Currently Lion comes with no JDK – you need to install it manually. Also Lion does not support 32bit JDK anymore. So I suspect you installed Lion, but JDK remains from your previous installation, which is not compatible with Lion.

    The actual JDK can be downloaded from – please give a try.


    The JDK works fine, I use it for Tomcat, Spring and work with it as usual. It’s also been updated automatically a couple of times since I got Lion.


    Please help, someone.

    Presumably something is simply missing, but there are no log messages at all to give an idea. Probably the Lion idea is a red herring.
    I did a complete reinstall of Snow Leopard a couple of weeks before updating to Lion and it may have happened then.

    Here’s a very simple test below. The code is correct, of that I’m certain.
    The debug just prints out “version: PD4ML 380 Pro” and then it all hangs….

    All the correct .jars are on the classpath- I currently have:

    Any help would be very gratefully received.

    <%@page import="org.zefer.pd4ml.PD4Constants"<br /> %><%@ taglib uri="" prefix="pd4ml"<br /> %><%@page language="java" contentType="text/html; charset=utf-8" pageEncoding="utf-8"%><pd4ml:transform<br /> pageFormat="A4"<br /> pageOrientation="portrait"<br /> screenWidth="700"<br /> pageInsets="10,50,20,50,points"<br /> debug="true"><br /> <html><br /> <head><br /> <br /> </head><br /> <body><br /> <br /> hello<br /> </body><br /> </html><br /> </pd4ml:transform>


    The JSP sample is very basic and as I see is absolutely correct. The library set is also complete. So obviously something is wrong with the environment.

    If you are absolutely sure there is no error messages and stack traces in both server STDOUT and STDERR logs, please try to run an offline test:

    java -Xmx512m -jar pd4ml.jar

    It should run PD4ML in GUI mode. Try to open an HTML and to convert it to PDF. Does it work?


    Thanks for your help.

    I’ve been trying to run the command-line pd4ml class but whatever I do I get: Cannot run program “/Applications/”: error=13, Permission denied

    I’ve created a folder with completely open permissions to everyone, and I run the pd4ml class from there.
    I also changed the permissions for the Mac preview app so that it has permissions to be run by any user.

    The pd4ml class will open and show my simple html file when I press GO.
    But will not create a .pdf when I press PDF – for the reason shown above.


    P.S. There have never been any messages at all in my Tomcat stdout and stderr logs. Complete silence. And any calls to pd4ml just hang forever, without timeout.

    My Lion update was quick and practically painless, which was perhaps too good to be true. I’ve had no problems at all with any other programmes.

    Presumably something is missing, however. PD4ML doesn’t depend on any system graphics does it?


    > The pd4ml class will open and show my simple html file when I press GO.

    It is a good sign. It means PD4ML works and renders HTML (in the case not to PDF, but to Image output device). I guess it also produces PDF to a TMP directory, but it cannot start a viewer application for some reason.

    The problem with Tomcat still has no good explanation. I would recommend to try to configure a progress monitor:

    It should help us to determine at which conversion phase it fails.


    Ok, tried the Progress Meter

    This is all I get, I’m afraid:

    0 0 conversion begin


    My colleague who also has just installed Lion has the same problem, exactly the same.

    I have tried updating to 3.8.0fx4 but it made no difference.


    Currently on my workstation is installed OSX 10.7.2 – no problems with PD4ML at all.

    Just noticed:

    > I’ve been trying to run the command-line pd4ml class but whatever I do I get:
    > Cannot run program “/Applications/”: error=13, Permission denied

    Pd4Cmd does not try to run Probably you are trying to convert with PD4Browser. Run Pd4Cmd instead:


    Sorry for the delay, I hadn’t gone to sleep, I was on holiday.
    Thanks for your continuing help.

    The following command produced a nice pdf:

    java -Xmx512m -Djava.awt.headless=true -cp ./pd4ml.jar Pd4Cmd ‘; 1200 LETTER -bookmarks HEADINGS -pdfforms -debug -out /tmp/pd4ml.pdf

    The only question is: why doesn’t it produce anything from Tomcat6 (which is also headless)? We get nothing from either API calls or tags


    Does your product or Tomcat installation includes GWT-DEV.jar?


    No, we don’t use GWT, and the .jar you mention is not among our libraries.

Viewing 15 posts - 1 through 15 (of 33 total)

The forum ‘Deployment / Configuration issues’ is closed to new topics and replies.