Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #26283

    My sample HTML like this :

      Department  EMPLOYEE  SCHEDULED  WORKED  Last Name  First Name  Emp ID  Phone Number  Shift  Hours  Shift  Hours 

    And i am setting enableTableBreaks property ‘True’. My application deployed in glassfish server. And my pdf contains more than one page.

    In PDF, first page showing double headers properly. From second page onwards, second header not getting displayed i.e Last Name, First Name, Emp Id, Phone Number etc header. But first header displaying properly. i.e. Department, EMPLOYEE, SCHEDULED, WORKED header.

    Can you please let me know why this issue coming in glassfish server. It’s properly working when my application deployed in tomcat.

    Please check the attached Image “SecondHeaderMissing_pdf2.GIF” for clarification.


    Is the problem reproduceable with the most recent version of PD4ML (v351)?


    I am using pd4ml 2.6 version. Don’t know about most recent version(V351). Can you please check with version 2.6 why this issue was coming and provide the patch.


    According to the release notes the feature is added in v323b4. Before that, PD4ML was able to replicate only single row headers.


    sorry.. i am using below mentioned PD4ML version
    Implementation-Title: PD4ML Pro
    Implementation-Version: 324
    These details mentioned in manifest file of pd4ml.jar.
    Can you please check once again why this issue was coming?


    I’ve just checked the issue with v351 and on my workstation it works correctly. Please upgrade.


    We are using 371b1 Pro (Trial), and we does encountered the mentioned ‘double header’ issue.

    On our side, I generate the webpage with JSP, and assign header using JAVA code. As we try to print our paperwork on an A4 page in landscape with 2 columns, so as to simulate 2 A5 printout side by side.

    The header has 100px tall but it seems to spare 200px tall. The header is not duplicated itself, just left a white space below itself.

    And the header is not shown except page 1.

    I does turn on the enableSmartTableBreak(true), while header contains a table. The height of the header is set to -1 so as to let it decide the height automatically.

    Is there any incorrect setting I need to take care? Does my given information enough for you to check out what is wrong?

Viewing 7 posts - 1 through 7 (of 7 total)

The forum ‘Troubleshooting’ is closed to new topics and replies.