Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #27081

    We have a web application using pd4ml running on:

    java 6
    weblogic server 10.3
    pd4ml 370fx2

    We had occasionally Out Of Memory error with thread stucked on:

    which is more than the configured time (StuckThreadMaxTime) of “600” seconds. Stack trace: Method)

    org.zefer.pd4ml.pdf.e.o00000(Unknown Source)

    org.zefer.pd4ml.pdf.c.public(Unknown Source)

    org.zefer.pd4ml.pdf.c.֏0000(Unknown Source)

    org.zefer.pd4ml.pdf.PD4Device.startNewPage(Unknown Source)

    org.zefer.pd4ml.PD4ML.o00000(Unknown Source)

    org.zefer.pd4ml.PD4ML.render(Unknown Source)

    org.zefer.pd4ml.PD4ML.render(Unknown Source)

    Is it possible that newer version of library solved this problem ?


    One year ago it was a report of a similar issue on
    JRE 1.7.0u67
    CentOS 6.6 x64

    The error had also been thrown by It is a very standard Java class and we did not touch the corresponding code probably since versions 2.x of PD4ML and never had troubles with it before.

    Last time we suspected a JDK installation inconsistencies (or may be even a palform-specific bug), occasionally hit by v3.6.1b1. A JDK re-install and a switching to v3.9.5 have solved the issue that time. But we did not determine what exactly was “the cure”. I would recommend to switch to PD4ML v398fx5; and if it does not help, to re-install the JDK.

Viewing 2 posts - 1 through 2 (of 2 total)

The forum ‘General questions / FAQ’ is closed to new topics and replies.