Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #34752

    So I have been using pd4ml for a long time. We mainly use the render method and pass it a url for the jsp in question. There are times we use the OutputStream of the HttpServletResponse, and sometimes we Use a FileOutputStream and save a pdf on a file system. It was just brought to my attention that the pdf files are being created and are blank. They are about 2K in size instead of 600-700K. PDFs in the Browser are just fine. These PDFs were being written to a File Server directly. I decided to try to write locally on the web server to a temp folder and then copy. On my local machine that worked just fine. But when I promoted to my DEV server, the file being written to the temp folder was blank.

    This is PD4ml v.3, running on Tomcat9, Java 8. My local workstation and dev server are pretty close version-wise, although I am running Eclipse and a local Tomcat instance in that, and the dev server is running the Tomcat Service Wrapper. But both are Tomcat9, Java8, etc. Any ideas why it would run ok on my instance, but not DEV?

    I did upgrade from Tomcat7 recently, so that could be related, but then I shouldn’t be able to work on my local instance. I can’t revert Tomcat to v7 for security reasons, and would think this should be able to work given it works for my local instance. Any help is appreciated!


    Please enable debug mode of PD4ML and inspect the server logs for possible PD4ML error messages or diagnostic output.
    Also please open the generated 2K PDFs in a text editor and copy-paste its content to the thread to be reviewed. Thanks!


    I was able to fix this. It ended up being an HTTP/HTTPS issue. It was something I fixed in a few spots months ago, but apparently missed one. I am able to make sure the url is HTTPS and it is all good.


    Glad the issue is solved!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.