Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #26798

    Hi there

    Using a string as a parameter to pass to PHP’s exec() function appears to not do anthing for me, but copying and pasting the string into Terminal creates the PDF as I require.

    I would like to debug it to see whats up, but I can’t work out from the docs how to do this.

    This is my string:

    cd; java -debug -Djava.awt.headless=true -Xmx512m -Xbootclasspath/a:ss_css2.jar -jar pd4ml.jar 'http://domain/test.php?id=x' -out /tmp/50b75b0abc95e.pdf

    Any help would be gratefully received.

    I’m sure its not a user permission as I had something working earlier.


    It turned out, that the apache user was having issues reading the JAR file, but not reporting it.

    So, in the exec I now cd into the correct folder (explicitly) and it works fine.

    Just took a lot of working out as I had no real error information, until I worked out which user apache was running under (_www) and running the command as that user.

    Incase anyone else has this issue…


    Glad you solved the issue and thank you for the sharing of the solution with us!

Viewing 3 posts - 1 through 3 (of 3 total)

The forum ‘Troubleshooting’ is closed to new topics and replies.