Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #26535


    i have a problem parsing png images … please let me know how to solve it



    i cant parse PNG images , please tell me how to solve that




    please find the PNG that causes the parsing problem attached to the message . also find html that includes the image below

    Untitled Page




    ????? ??? ??????

    ????? ????

    ????? ???? ??? ??????

    ????? ??? ??????

    ????? ????

    ????? ???? ??? ??????


    ???? ???????? ??????? ???????
    ????? ????????
    ??????? ?????? ????? ??????
    ????????? ????????? ??????????? ????????????
    ???????? ????????? ??????
    United Arab Emirates
    Ministry of Interior
    Abu Dhabi Police G.H.Q
    Human Resources General Directorate
    G. Director Office

    ???????? : 11/2/33
    ????????? : 15/10/2007 ?
    ????????? : 03/???? /1428 ??

           ???? ?????? ????? ??????? ???????
    ???????  :   ???? ????????
    ?? ???? ??

    ????????? ???? ??????????????
    ???? ??? :

  • asdfasdf
  • 500254 – 10/10/2007

  • thanks


    Unfortunately there is no PNG attached.

    Could you please try to attach once more?



    ok now you can find it attached to the message and by the way its a signature

    thank you very much



    can i get any update on this issue please



    Below is a copy of email sent to your email address ( on Apr. 07, 2011

    I had no problems to convert an HTML with your image to PDF (see attached).

    Is it exactly the same image, that caused the problem? As I see in your HTML sample there is no test_png.png reference.

    Also in the servlet code please try to invoke,%20HttpServletResponse)
    method before pd4ml.render()

    Does it change anything?



    ok i will try again to do the change that you are refering to but please tell me exactly what do you mean by this

    Also in the servlet code please try to invoke,%20HttpServletResponse)
    method before pd4ml.render()

    can you please clarify



    i have tried the following html code and also i have embadded the png image , the same one attached previously

    line one
    line two line three

    and i am getting the following error

    java.lang.NumberFormatException: For input string: “/F”
    at java.lang.NumberFormatException.forInputString(
    at java.lang.Integer.parseInt(
    at org.zefer.pd4ml.pdf.h$_b.o00000(Unknown Source)
    at org.zefer.pd4ml.pdf.c.OÒ0000(Unknown Source)
    at org.zefer.pd4ml.pdf.c.ø00000(Unknown Source)
    at org.zefer.pd4ml.pdf.c.close(Unknown Source)
    at org.zefer.pd4ml.pdf.PD4Device.dispose(Unknown Source)
    at org.zefer.pd4ml.PD4ML.o00000(Unknown Source)
    at org.zefer.pd4ml.PD4ML.render(Unknown Source)
    at ae.rwd.model.Pdf.convertHtmlToPdf(
    at ae.rwd.servlet.PdfCreater.processRequest(
    at ae.rwd.servlet.PdfCreater.doGet(
    at javax.servlet.http.HttpServlet.service(
    at javax.servlet.http.HttpServlet.service(
    at org.apache.catalina.core.StandardWrapper.service(
    at org.apache.catalina.core.StandardWrapperValve.invoke(
    at org.apache.catalina.core.StandardContextValve.invoke(
    at org.apache.catalina.core.StandardPipeline.invoke(
    at com.sun.enterprise.web.WebPipeline.invoke(
    at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(
    at org.apache.catalina.core.StandardHostValve.invoke(
    at org.apache.catalina.connector.CoyoteAdapter.doService(
    at org.apache.catalina.connector.CoyoteAdapter.service(
    at com.sun.grizzly.http.ProcessorTask.invokeAdapter(
    at com.sun.grizzly.http.ProcessorTask.doProcess(
    at com.sun.grizzly.http.ProcessorTask.process(
    at com.sun.grizzly.http.DefaultProtocolFilter.execute(
    at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(
    at com.sun.grizzly.DefaultProtocolChain.execute(
    at com.sun.grizzly.DefaultProtocolChain.execute(
    at com.sun.grizzly.http.HttpProtocolChain.execute(
    at com.sun.grizzly.ProtocolChainContextTask.doCall(
    at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(
    at com.sun.grizzly.util.AbstractThreadPool$





    call in your servlet code you need to invoke

    pd4ml.useHttpRequest(httpRequest, httpResponse);

    (where parameters are HttpServletRequest httpRequest and HttpServletResponse httpResponse)


    i tried that but its not working , i get the same error . i am sure its the png image i mean if i change the type of the image to any other type then its ok but when i try png its not working

    please help me



    this issue has been hanging for long time . please can i get an answer

    thank you


    As we wrote you before, the problem is caused by a corrupted PNG file. The original file seems to be ok, but probably it is damaged on the way to PD4ML. PD4ML only states that during parsing of the image by particular offset if found garbage instead of a numeric value.

    Today we’ll prepare a version with a binary data dump, to check what is actually returned by PNG request. We’ll send you the version by email.



    ok thank you , i will wait for this version . hopefully we will get this ping issue solved after this invistigation .

    thanks alot


    Does it work with the patched version?

Viewing 15 posts - 1 through 15 (of 15 total)

The forum ‘HTML/CSS rendering issues’ is closed to new topics and replies.